Back to overview
Downtime

Internal Server Issues

Aug 31 at 03:33pm EEST
Affected services
Web App

Resolved
Sep 02 at 04:59am EEST

We are back online

Created
Aug 31 at 03:33pm EEST

Our web app is currently unavailable due to increased internal server issues from auto scaling functions on our host and we are already working on it to get it back asap. We'll keep you updated!