Back to overview
Degraded

Elevated Server Issues

Dec 01 at 10:06pm EET
Affected services
Web App
Billing

Resolved
Dec 05 at 06:17pm EET

Issue is resolved and all services are back online. Thank you for your patience!

Created
Dec 01 at 10:06pm EET

We are experiencing an elevated 503 server issues at the moment. We are working on it to fix the issue and keep you updated once we have more news.