Back to overview
Downtime

Downstream Service Disruption

Jan 28 at 06:33pm EET
Affected services
Web App
Website

Resolved
Feb 12 at 01:47pm EET

Resolved. Thanks for your patients!

Updated
Feb 12 at 04:09am EET

We are revamping or internal structure for better stability. All services are going down during this period and I apologies for that. Expect to be up within 24-48h

Created
Jan 28 at 06:33pm EET

We are aware of a disruption impacting downstream services and are working to resolve it promptly. Thank you for your patience.