Back to overview
Degraded

Ongoing Incident with CDN & Storage Provider

Mar 26, 2026 at 3:29pm UTC
Affected services
CDN

Resolved
Mar 26, 2026 at 4:40pm UTC

Back online!

Created
Mar 26, 2026 at 3:29pm UTC

All the generative tools are turned off due to an ongoing incident with our CDN & Storage provider. Not much we can do as of now till they fix this issue. We'll keep you updated.