Back to overview
Downtime

Hosting Failure

May 1, 2026 at 2:28pm UTC
Affected services
Web App

Resolved
May 3, 2026 at 7:58am UTC

Back online

Updated
May 2, 2026 at 2:58pm UTC

Google taking longer than expected to respond.

Created
May 1, 2026 at 2:28pm UTC

We have encountered a critical hosting failure and are currently working on a fix. We'll keep you updated.