Back to overview
Resolved

New Accounts Creation Temporarily Paused

Jul 29, 2026 at 5:38pm UTC
Affected services
Billing

Resolved
Aug 1, 2026 at 5:00pm UTC

Fixed

Created
Jul 29, 2026 at 5:38pm UTC

New account creation is temporarily unavailable while we migrate to a new hosting provider and authentication system. Existing accounts remain fully available, but some users may experience issues when attempting to reset their passwords during this period.

We are actively working to complete the migration and restore normal signup and password reset functionality as soon as possible. If you need assistance accessing your account, please contact our support team.